Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Mod Updates for 1.5

Mod Updates for 1.5

All the mods are now compatible with Minecraft 1.5.
Plus some significant changes to MoreMeat allow it to work better with other mods.

Get them here.


Martin 17 March 2013 79,245 0 comments 0 out of 0 ratings

0 comments

Leave a Comment

Please Login to Post a Comment.
  • No Comments have been Posted.

Rating is available to Members only.
Please Login to vote.
Awesome! (0)0 %
Very Good (0)0 %
Good (0)0 %
Average (0)0 %
Poor (0)0 %